Skip to content

Komplete Kontrol not playing after re-opening a project in samplitude: solved

Posted in Tips, Tricks and Trouble Shooting

Komplete Kontrol and the S series of keyboards are giving first class access to a host of plugins, but it’s not always plain sailing when it comes to set up. here we have a problem that was eventually solved, so this is always something worth trying if you have the same kind of issues. Thanks go out to Kevin Gibbs for posting this.

Issue:
You load an instance of Komplete Kontrol on to a track in Samplitude, and all works as expected, but on saving and re-opening the project, those tracks don’t sound, even though the instance of Komplete Kontrol is still on the track.

How it was solved.
After determining that all the monitoring settings were correct in the monitoring menu (transport/control alt shift F twice), e.g:
Monitoring checked.
Manual Monitoring Unchecked.
Tape Monitoring Checked.
Automatic Midi Record Switch on current track checked.
Automatic Midi Monitoring (Thru)checked
No Audio Monitoring (Peak monitoring only) unchecked
Hardware Monitoring Unchecked.
Software Monitoring Economy Engine Unchecked.
Track FX Monitoring Unchecked.
Hardware Monitoring/hybrid Engine checked.
Mixer FX Monitoring / Hybrid engine unchecked.
We looked back at the VstPlugins.INI and VstPlugins.0 files. Curiously, the date on the VstPlugins.0 file was from five days ago. So, that let us know that a new one had not been created when we did the complete rescan. This remains a mystery, But a new VstPlugins.INI file was created.

After some thought, we looked at the VST.ini file for references to Komplete Kontrol, as this file contains all the paths to VST’s on your system. It was then we noticed multiple references to Komplete Kontrol, that were not the default install location. The default location should be:
C:\Program Files\Native Instruments VSTPlugins 64 bit.
but there was a reference to:
C:\Program Files\VST64.

Now, with the large amount of VST’s users can have on their system, it’s always possible to get confused…and sometimes we can move DLL’s around in order to group VST’s together. Add to this that some people use more than 1 DAW…and it’s easy to see how things can easily get messed up.

Anyway, this was solved by deleting the reference to:
C:\Program Files\VST64 and resaving the VST.ini file.,
It seems as if Samplitude had 2 versions of this plug, hence the reason why it was causing issues when re-opening a saved project.
Eliminating this confusion appears to have resolved Samplitude’s connection of Komplete Kontrol to tracks.

Can’t say enough about Steve’s patience. This is by no means the first time he has sweated it out with me over things that shouldn’t have gone wrong.

Gratefully,
Kevin

Be First to Comment

Leave a Reply

Your email address will not be published. Required fields are marked *